NUnit 2.5.7 Compatibility?

Aug 19, 2010 at 9:39 AM
Edited Aug 19, 2010 at 9:48 AM

Hi,

I'm having problems getting the following script to run.

I have updated the NunitAddin.dll  but, it still does not recognise WebTestFixture. I now also get a warning telling me "Found conflicts between different versions of the same dependent assembly."

Can you advise?

I'd really like to use this toolkit as it simplfys the setup of Selenium.

 

Cheers,

 

Daz

 

UPDATE: I thought thre may be a clash with the existing Selenium and Nunit dlls  so I started a fresh project.  I still get issues with WebTestFixture and WebTestFixtureAttribute nott being found.

Coordinator
Aug 19, 2010 at 1:41 PM

I'm assuming these errors are NUnit specific?  Which version of NUnit are you using?

Aug 19, 2010 at 3:15 PM
I think they are related to NUnit,  I'm using 2.5.7.

On 19 August 2010 14:41, bcook <notifications@codeplex.com> wrote:

From: bcook

I'm assuming these errors are NUnit specific?  Which version of NUnit are you using?

Read the full discussion online.

To add a post to this discussion, reply to this email (seleniumtoolkit@discussions.codeplex.com)

To start a new discussion for this project, email seleniumtoolkit@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Coordinator
Aug 19, 2010 at 9:16 PM
Edited Aug 20, 2010 at 2:32 PM

Currently, the MSI on the downloads page (version 0.81) is only compatible with NUnit 2.5.2.  This has to do with how NUnit addins have to reference the NUnit library there were created with, however re-compiling the source with new dependencies is all that's needed in most cases.

As per my recent post on my blog, adding support for 2.5.7 is something I hope to tackle this weekend.  I'd like to create a full new release, but I need to fix the installer to support multiple installed versions of NUnit (2.4.8, 2.5.3, 2.5.5, 2.5.7).  It's just time at this point.

Incidentally, this work item has an attachment with an interim support for 2.5.3 (http://seleniumtoolkit.codeplex.com/workitem/10532).  I can do the same for 2.5.5 and 2.5.7.

 

 

Aug 20, 2010 at 2:22 PM

Yes I saw that post and actually tried that file but, obviously it was for the wrong version on nUnit.  If you have a chance to put to gether a version for 2.5.7  that would be handy.

Coordinator
Aug 20, 2010 at 2:28 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.